It is recommended that if possible you upgrade your PHP to 7 or 7.1 as it will bring a considerable speed boost to your site.

Also, if you are using the Hathor backend template you should switch to the Isis template as your administrative template. The Hathor template is being deprecated and may not provide you with the ability to use all the latest features in Joomla! 3.7.

I offer an upgrading package if you are nervous about doing this yourself, please visit my website for more details: http://www.xpressionwebs.com/se…/website-updates-maintenance